Lightspeed OnSite Omnichannel processing delays
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted 17 days ago. Jun 06, 2017 - 17:30 EDT
Investigating
Some customers are experiencing delays in Product updates and Order downloads. Your Product updates and Order downloads will not be lost and our systems will be processing normally shortly.
Posted 17 days ago. Jun 06, 2017 - 16:41 EDT
This incident affected: Lightspeed OnSite (Omnichannel Integration).