Possible Performance Issue
Incident Report for Lightspeed - Status Page
Resolved
The slowness has been alleviated and the issue has been resolved. If you are still experiencing issues we recommend shutting down your browser and opening it up again.
Posted May 17, 2017 - 13:17 EDT
Monitoring
Customers should be seeing functionality return. If you are still experiencing issues please log out and then back in. We are closely monitoring the issue and will update once the incident is fully resolved.
Posted May 17, 2017 - 12:58 EDT
Identified
We have identified the issue with our systems which is creating slowness with navigating Lightspeed.
Posted May 17, 2017 - 12:30 EDT
Investigating
Our automated systems have identified a potential performance issue. We're currently investigating and will update as we learn more.
Posted May 17, 2017 - 12:01 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS).