Issue with Cayan Processing
Incident Report for Lightspeed - Status Page
Resolved
Cayan has sent a patch to update the Genius devices that were affected. If you are still experiencing issues please contact Cayan at 844.278.7115.
Posted May 09, 2017 - 11:39 EDT
Identified
Recently, customers processing on Cayan's Genius terminal have experienced disconnection issues. It is recommended that you unplug the terminal from the power and plug it back in. If you are still experiencing connection issues please contact Cayan at 844.278.7115.
Posted May 06, 2017 - 17:13 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS).