Quality Bicycle Products Online Ordering
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted May 06, 2022 - 10:45 EDT
Investigating
Online Ordering and Invoice Downloads for the Quality Bicycle Products vendor are temporarily unavailable due to an issue on QBP’s servers. We have contacted the vendor to investigate the issue.
Posted May 05, 2022 - 14:44 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS).