Delay in processing sales history, products and customer updates
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Dec 12, 2022 - 00:14 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2022 - 00:10 EST
Investigating
We are currently investigating this issue.
Posted Dec 12, 2022 - 00:06 EST
This incident affected: Lightspeed Retail (X-Series) (Customer Management, Sales History, Products).