Order Confirmation Email Delivery Issue - Lightspeed eCom (NoAm)
Incident Report for Lightspeed - Status Page
Resolved
Our engineers have deployed a fix. Backlogged confirmation emails should be received shortly.
Posted 20 days ago. Nov 28, 2018 - 15:02 EST
Identified
We have detected an issue with our Order Confirmation Email Delivery System affecting merchants in North America. Our engineers are investigating the problem and all unsent Order Confirmations will be sent out once the issue is resolved

We will update this incident notification as we learn more.
Posted 20 days ago. Nov 28, 2018 - 14:44 EST
This incident affected: Lightspeed eCom (Lightspeed eCom (North America & Australia)).