Retail Home (Dashboard) not accessible
Incident Report for Lightspeed - Status Page
Resolved
Our cloud provider has resolved the issue.
Posted 11 days ago. Jun 04, 2019 - 18:54 EDT
Identified
We have identified the root-cause of not loading the Retail Home Dashboard. Our cloud provider has identified connectivity issue’s in and between certain regions, affecting our Retail Home dashboard. Main workflows are operational.

More information: https://status.cloud.google.com/incident/cloud-networking/19010
Posted 11 days ago. Jun 04, 2019 - 18:03 EDT
Investigating
We are currently investigating an issue with the Retail Home / Dashboard pages
Posted 11 days ago. Jun 04, 2019 - 17:51 EDT
This incident affected: Lightspeed Retail (Retail POS).