Elevated Payments Errors Detected
Incident Report for Lightspeed - Status Page
Resolved
The third-party partner has resolved the issue. Transactions are now being processed normally.
Posted Mar 27, 2020 - 17:23 EDT
Monitoring
We are no longer seeing a degradation in performance and we are currently monitoring the system.
Posted Mar 27, 2020 - 17:00 EDT
Investigating
We have identified an issue with Lightspeed Payments. A dedicated team is researching the issue. We will update you as more information becomes available.
Posted Mar 27, 2020 - 16:02 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).