Elevated Payments Errors Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
No new errors have been reported. Incident will be closed.
Posted 22 days ago. May 25, 2019 - 10:52 EDT
Monitoring
The error rate has reduced, we remain to monitor the issue.
Posted 22 days ago. May 25, 2019 - 10:25 EDT
Investigating
We are currently investigating this issue.
Posted 22 days ago. May 25, 2019 - 10:02 EDT
This incident affected: Lightspeed Retail (Retail POS).