Lightspeed Hospitality - K Series - Possible delay in Online Orders
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 10:06 EST
Investigating
We are currently investigating the issue.
Posted Nov 11, 2021 - 08:25 EST
This incident affected: Lightspeed Restaurant K-Series (API (incl. Online Orders)).