Lightspeed Payments - performance degradation
Incident Report for Lightspeed - Status Page
Resolved
Customers should have begun to experience regular service.
We apologize to all who were affected by the disruption.
Posted Oct 24, 2020 - 14:50 EDT
Monitoring
A degradation of our third-party service provider has resulted in Lightspeed Payments transactions timing out in some cases. The service provider is investigating the issue.
Posted Oct 24, 2020 - 13:28 EDT
Identified
We have identified an issue with a 3rd party which is impacting the performance of Lightspeed Payments transactions in some cases.
Posted Oct 24, 2020 - 11:18 EDT
This incident affected: Lightspeed Payments.