Lightspeed Hospitality - K Series Online Orders
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved
Posted May 12, 2021 - 00:39 EDT
Monitoring
A fix has been implemented and we are monitoring the result.
Posted May 11, 2021 - 13:56 EDT
Investigating
We see a delay in the processing of Online Orders. We are currently investigating the issue.
Posted May 11, 2021 - 13:27 EDT