Elevated Payments Errors - Lightspeed Payments & Worldpay
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jul 18, 2019 - 18:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2019 - 17:40 EDT
Update
Lightspeed Payments and Worldpay continue to be unable to process payments. Our teams are working closely with Worldpay to try to resolve the issue.
Posted Jul 18, 2019 - 15:15 EDT
Update
We’re continue to work on resolving the issue. We will post updates as they become available.
Posted Jul 18, 2019 - 13:33 EDT
Update
We are continuing to work on resolving this issue. We appreciate your patience and apologize for the inconvenience.
Posted Jul 18, 2019 - 12:28 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2019 - 11:06 EDT
Investigating
We are currently investigating issues with payments not completing and will post an update shortly.
Posted Jul 18, 2019 - 10:42 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).