Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
We have received reports from Lightspeed Retail merchants using older versions of MacOS experiencing issues with Lightspeed Hub, Home, and some payment terminals. This is due to expired certificates within the operating system itself. If you are impacted, we recommend that you update your MacOS to version 10.12 or higher.
Posted Sep 30, 2021 - 14:09 EDT
Identified
This issue has been identified.

We have received reports from merchants using older versions of MacOS experiencing issues with Lightspeed Hub, Home, and some payment terminals. This is due to expired certificates within the operating system itself. If you are impacted, we recommend that you update your MacOS to version 10.12 or higher.
Posted Sep 30, 2021 - 13:44 EDT
Investigating
We are currently investigating an issue affecting some merchants using Lightspeed Retail on devices using older operating systems versions and browsers. A dedicated team is investigating the issue.
Posted Sep 30, 2021 - 13:35 EDT
This incident affected: Lightspeed Retail (Retail POS, Retail Integrated Payments).