Lightspeed Restaurant (O-Series) - Updates & New Improvements 11.19.0

Scheduled for Sep 22, 01:00 - 02:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Monday, September 22 at 15:00 AEST
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.

NEW
- Orders on the same table can now be merged directly from the Tables screen.

IMPROVED
- Customer lists in Back Office now load much faster, even with very large numbers of customers.
- Table updates in POS are now faster and more reliable.
- The POS Users list now performs better on all devices.

RESOLVED
- Fixed an issue where POS users on mobile devices could not navigate between multiple option sets.
- Fixed an issue where pressing Return/Enter in the Order Notes field did not create a new line.
- Fixed an issue where option set rules blocked updates in Product Availability edit mode.
- Fixed an issue where customer import completion emails were not being sent.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Sep 16, 2025 - 00:28 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).