Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 11:20 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2021 - 11:05 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 30, 2021 - 10:59 EDT
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Retail. Some users are not being able to log into Retail. A dedicated team is investigating the issue.
Posted Mar 30, 2021 - 10:39 EDT
This incident affected: Lightspeed Retail (Retail POS).