Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
The issue with Lightspeed Payments has been resolved. Transactions are now being processed normally.
Posted Nov 28, 2020 - 14:08 EST
Monitoring
We have implemented a fix and will continue to monitor the situation.
Posted Nov 28, 2020 - 13:31 EST
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Payments. A dedicated team is investigating the issue.
Posted Nov 28, 2020 - 13:27 EST
This incident affected: Lightspeed Payments.