Elevated Payments Errors - Lightspeed Payments & Worldpay
Incident Report for Lightspeed - Status Page
Resolved
Payment systems have been returned to normal. Thank you for your patience.
Posted Jul 13, 2019 - 17:21 EDT
Monitoring
We are seeing error rates declining and payments services returning to normal. We will continue to monitor.
Posted Jul 13, 2019 - 16:51 EDT
Update
We are continuing to investigate this issue.
Posted Jul 13, 2019 - 16:27 EDT
Investigating
We are currently investigating issues with payments not completing and will post an update shortly.
Posted Jul 13, 2019 - 16:04 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).