Lightspeed Hospitality - L Series Order Ahead (EMEA)
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jun 01, 2021 - 09:20 EDT
Update
We are continuing to investigate this issue.
Posted Jun 01, 2021 - 05:18 EDT
Investigating
Lightspeed Hospitality, L Series Order Ahead is currently experiencing technical difficulties. Some orders cannot be sent and processed. We are currently investigating the issue.
Posted Jun 01, 2021 - 05:06 EDT
This incident affected: Lightspeed Restaurant.