Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 16:04 EDT
Identified
The issue has been identified by our partner. A dedicated team has been assigned.
Posted Oct 21, 2021 - 15:39 EDT
Investigating
We are currently investigating an issue affecting merchants using WorldPay or Lightspeed Payments with MX915 terminals. A dedicated team is investigating the issue.
Posted Oct 21, 2021 - 15:15 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).