Lightspeed Retail (X-Series) - Out of Date Inventory Information
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 10, 2022 - 16:02 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2022 - 13:18 EST
Identified
We are currently investigating an issue which is causing some merchants to experience delays in inventory processing.
Posted Nov 10, 2022 - 12:10 EST
This incident affected: Lightspeed Retail (X-Series) (Inventory).