Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
This incident is now considered to be resolved. Please update the Lightspeed Retail POS iPad app to version 3.3.1 for the fix to be implemented.
Posted May 12, 2020 - 13:49 EDT
Identified
We have identified the cause of the Lightspeed Retail iOS app issue and a dedicated team of engineers is working on a solution. We are currently waiting for an updated version of the app to be approved by the App Store.
Posted May 12, 2020 - 09:38 EDT
Update
We have identified an issue affecting payments when using Worldline terminals and the Retail iPad app. These terminals show up as "not connected" in the iPad app while the terminal says "ready" to accept payments. If you have not done so, please do not update your iPad app to the latest version.
Posted May 12, 2020 - 05:21 EDT
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Retail. A dedicated team is investigating the issue.
Posted May 12, 2020 - 05:11 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS, Retail API).