Performance Degraded - Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jul 13, 2019 - 11:33 EDT
Investigating
We have identified an issue with the Home page of Lightspeed Retail. Take note that all other features are fully operational. A dedicated team is researching the issue. We will update you as more information becomes available.
Posted Jul 13, 2019 - 11:12 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS, Retail API).