Lightspeed O-Series - Issue with Subscription Invoice Payments

Incident Report for Lightspeed - Status Page

Resolved

The issue affecting credit card payments for Lightspeed Subscription Invoices has now been resolved.

Our payment provider has confirmed that payment processing has been restored, and users should no longer encounter the "Processor Network Unavailable—Try Again." error when attempting to pay invoices.

If you continue to experience issues, please contact our support team for assistance.

Thank you for your patience.
Posted Feb 13, 2025 - 01:18 EST

Investigating

We are aware of an issue where some users may see the error message "Processor Network Unavailable—Try Again." when attempting to pay their Lightspeed Subscription Invoice via credit card.

This is due to a temporary payment processing issue affecting Australia and New Zealand. The issue is ongoing, and we are actively monitoring updates from our payment provider.

Failed payments will be retried automatically—no manual action is required. If you have concerns about your site being downgraded due to a failed payment, please contact our support team for assistance.

We will provide further updates as soon as more information becomes available. Thank you for your patience.
Posted Feb 12, 2025 - 22:12 EST
This incident affected: Lightspeed Restaurant (O-Series) (Payment Integrations).