Lightspeed Retail - Issues with Customer Facing Display
Incident Report for Lightspeed - Status Page
Resolved
The Customer Display is now working as expected. If you are still experiencing issues please contact Support.
Posted 2 months ago. Oct 11, 2017 - 10:35 EDT
Update
The team is continuing to work on the Customer Display issues. Please check back here regularly for updates. Thank you for your patience.
Posted 2 months ago. Oct 10, 2017 - 11:07 EDT
Identified
Our engineers have identified the cause of the issue and are working on implementing a solution.
Posted 2 months ago. Oct 09, 2017 - 14:39 EDT
Investigating
We are investigating reports that the Customer Facing Display is not functioning for some accounts.
Posted 2 months ago. Oct 09, 2017 - 12:41 EDT