Lightspeed eCom (North America)
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 22:49 EDT
Investigating
We are currently investigating an issue affecting merchants using Lightspeed eCom in North America. A dedicated team is investigating the issue.
Posted Jul 09, 2020 - 22:22 EDT
This incident affected: Lightspeed eCom (C-Series) (Lightspeed eCom (North America & Australia)).