Lightspeed Restaurant (K-Series) Incident
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 17:07 EDT
Investigating
We are investigating an issue where some customers are unable to process payments with Lightspeed Payments.
Posted Jul 19, 2023 - 16:39 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Payments).