Service Disruption - Telephony
Incident Report for Lightspeed - Status Page
Resolved
Thank you for your patience, our telephony provider reports full recovery, which we are seeing across our systems.

You should now be able to reach our teams via phone.
Posted Nov 09, 2021 - 16:16 EST
Monitoring
Our provider reports recovery of services, we're starting to see improvement.

If you remain unable to reach us via phone, you can connect with us over another channel where we'll be happy to serve you.

To reach Sales please email sales@lightspeedhq.com
To contact Support, please reach out via Chat from within your Lightspeed product or submit a ticket on our Help Centres
Posted Nov 09, 2021 - 15:57 EST
Identified
We're experiencing technical difficulties receiving calls from our telephony providers. We are working with them to resolve the issue.


To reach Sales please email sales@lightspeedhq.com
To contact Support, please reach out via Chat from within your Lightspeed product or submit a ticket on our Help Centres
Posted Nov 09, 2021 - 15:21 EST