Return and Exchange Processing Errors

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 19:48 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 19:00 EDT

Investigating

We are currently investigating an issue impacting return and exchange processing under certain specific transaction conditions. Our engineering team are currently investigating the reported issue. We apologize for the inconvenience caused in the meantime
Posted Jul 23, 2026 - 18:35 EDT
This incident affected: Lightspeed Retail (X-Series) (Sales History).