Lightspeed Produce (O-Series) - Updates & New Improvements 3.3.0

Scheduled for Jun 28, 20:30 - 21:30 EDT

Scheduled

Update Time: Monday, June 29 at 10:30 AEST
Update Process: Lightspeed Produce will automatically update after 10:30 AEST.

IMPROVED
- Improved the reliability and performance of recipe loading for businesses with large recipe libraries.

RESOLVED
- Fixed an issue where saving a recipe could display an error even though the change had saved successfully.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jun 26, 2026 - 01:00 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (Produce).