Inventory, Product Search, Sales History and Online Channels delay

Incident Report for Lightspeed - Status Page

Resolved

The delay is gone.
There might be some remaining webhooks being sent to integrators.
Posted Jul 02, 2026 - 18:57 EDT

Monitoring

Some retailers may experience delays in updates made to the system showing throughout the system.
This impacts
- inventory levels slow in reflecting the right levels
- product added not appearing in searches and online store
- product updated not reflecting in searches and online store
- sales made may not be available in sales history

We have identified and resolving the issue and are monitoring system recovery
Posted Jul 02, 2026 - 18:21 EDT
This incident affected: Lightspeed Retail (X-Series) (Inventory, Products, Sales History).