Capital Application - Page not found
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted May 30, 2024 - 11:58 EDT
Investigating
We are investigating reports of stores not being able to process/proceed with the application. Error " Page not found" appears when clicked on proceed. We'll keep you updated as we find out more.
Posted May 20, 2024 - 19:59 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS).