O-Series & K-Series: Financial Services reports are delayed

Incident Report for Lightspeed - Status Page

Update

We are continuing to investigate this issue.
Posted Jun 02, 2026 - 22:10 EDT

Investigating

We have received reports where some customers are advising that approved transactions are stuck in "Authorized" status and payout reports are empty.

This is a cosmetic issue and payouts are actually not affected with deposits going through as expected, however our team are working to bring the reporting process back into alignment.
Posted Jun 02, 2026 - 21:45 EDT
This incident affects: Lightspeed Restaurant (O-Series) (Back Office, Lightspeed Payments) and Lightspeed Restaurant (K-Series) (Back Office - Reporting, Lightspeed Payments).