Delays - Sales Sync from E-Series Delayed

Incident Report for Lightspeed - Status Page

Resolved

Issue has been resolved, orders should sync without issues
Posted May 15, 2025 - 12:21 EDT

Investigating

We’re investigating an issue where sales sync from E-Com (E-Series) to Lightspeed Retail (X-Series) is delaying, and we will keep you posted as they come. Thanks for your patience.
Posted May 15, 2025 - 09:21 EDT
This incident affected: Lightspeed Retail (X-Series) (Sales History).