Slowness in the register flows
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 16:06 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2021 - 15:46 EDT
Investigating
We are currently investigating this issue.
Posted Mar 23, 2021 - 15:23 EDT
This incident affected: Lightspeed Retail (Retail POS).