Errors when accessing Golf

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 16:47 EDT

Monitoring

A fix has been implemented, and we are monitoring current performance.
Posted Aug 07, 2025 - 14:08 EDT

Investigating

Lightspeed Golf is currently experiencing an issue degrading app performance affecting many workflows. We are actively investigating this incident.
Posted Aug 07, 2025 - 12:51 EDT
This incident affected: Lightspeed Golf (Tee Sheets, Marketplace, House Accounts, Mobile Apps, Partner API).