Lightspeed Payments R-Series Issue
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 14:35 EDT
Monitoring
We have implemented a fix and are currently monitoring the situation.
Posted Jul 15, 2024 - 14:25 EDT
Investigating
We are currently experiencing an issue affecting R-series merchants using Lightspeed Payments. A dedicated team is investigating the issue.
Posted Jul 15, 2024 - 14:02 EDT
This incident affected: Lightspeed Retail (R-Series) (Integrated Payments).