Issues with UI on web selling screen that may be impacting workflows

Incident Report for Lightspeed - Status Page

Resolved

This has been resolved completely. Please try to refresh the page first if you still see issue persist to ensure the latest web assets are being loaded.
Posted Jan 20, 2026 - 02:36 EST

Monitoring

We have fixed the issue.
Workflows such as Marsello redemption and viewing customers on a sale should be reslved now
Posted Jan 19, 2026 - 20:53 EST

Identified

We have identified some UI issues on the selling screen that is impacting the ability of users to interact in workflows like Marsello redemption.

We are currently working on fixing this.
Posted Jan 19, 2026 - 19:26 EST
This incident affected: Lightspeed Retail (X-Series) (Retail POS).