Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 03, 2025 - 01:00 EDT
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, June 3 at 15:00 AEST Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.
RESOLVED - Fixed an issue preventing users from editing variant parent products (e.g. name, description, category), introduced in 11.11.0. - Resolved a login issue where users couldn’t access Insights directly via its web URL.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jun 02, 2025 - 22:20 EDT
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).