Intermittent Issues Viewing Customer Details in Sell Screen

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 14:21 EDT

Monitoring

We are currently investigating an issue where merchants are experiencing error messages when attempting to view or load customer details within the X-Series Sell Screen. Our engineering team has identified the cause and deployed a fix. Systems are recovering, and we are actively monitoring to confirm full resolution.
Posted Jul 27, 2026 - 13:08 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS).