Performance Degraded - Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 14:26 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2020 - 13:58 EST
Investigating
We are currently investigating this issue.
Posted Feb 26, 2020 - 13:49 EST
This incident affected: Lightspeed Retail (Retail POS).