We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, April 28 at 15:00 AEST Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.
NEW - Printers now automatically reconnect when their network address changes (for example after a router restart), so you no longer need to run “Find Printers”.
IMPROVED - Added accessibility markup across Back Office and POS. - Added a verification step when enabling MFA via Email OTP. - Added the ability to remove credit cards and bank accounts linked to deleted sites. - Improved messaging when a customer's mobile number matches an existing loyalty member at checkout. - Simplified Company Security settings in Back Office by removing the “Email OTP only” option; businesses previously using it have been moved to “Any method supported”. - Updated the Order Types prep-time description to reflect its actual behaviour — it applies to any API order without a set fulfilment time, including dine-in.
RESOLVED - Fixed an issue where duplicated printers with simultaneous printing enabled could cause printing failures. - Fixed an issue where accounting exports to Xero and MYOB could include incorrect (negative) tax values. - Fixed an issue where Tap-to-Pay transactions could be recorded against the wrong site after repurposing a device from another site. - Fixed an issue where GST was incorrectly calculated on Pay-at-Table receipts and on-account invoices for multi-quantity items. - Fixed an issue where incorrect payment surcharge totals were displayed on partial refund receipts for orders with order-level discounts. - Fixed an issue with the Products API availability filter to ensure consistent results. - Fixed an issue where loyalty billing charged sites on Lite or Pause plans in multi-site companies. - Fixed an issue where invoices were created when only $0 line items for features or integrations were present. - Fixed an issue where users locked out after failed login attempts could not access chat support from the login screen.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Apr 22, 2026 - 00:35 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).