Restaurant O-Series: Accounting Integrations
Incident Report for Lightspeed - Status Page
Resolved
We are continuing to work directly with several merchants that remain impacted, typically these are merchants with higher than average purchase orders or account sales.

The vast majority clients are caught up now however.
Posted Aug 16, 2024 - 02:46 EDT
Update
The vast majority of customers should be completely caught up with their Accounting data syncing.

There are a few outliers where reconciliations / takings data from August 10th onwards are still being re-tried in our backlog system.
We are also investigating further a collection of customers still seeing delays with On-Account and Purchase Order data.
Posted Aug 13, 2024 - 19:05 EDT
Update
We are currently syncing remaining account sales, with a few larger clients still running their backlog. The vast majority of these should complete later today, some larger backlogs may run overnight.

All takings/reconciliation data should be synced across and up to date.
Posted Aug 06, 2024 - 19:40 EDT
Update
All takings/reconciliations from customers should now be up to date (there's a handful customers with some remaining data for the 25th of July still being synced which should finish up very shortly).

We will soon be automatically restarting any invoices that were marked as "failed", we will also be batching all held up account sales shortly. This is a much smaller set of data so we anticipate all batched account sales finishing in the next 24-30 hours.
Posted Aug 05, 2024 - 17:58 EDT
Update
We are currently syncing over the last batch of data that is back logged.

July 24th and prior: should be all synced across.
July 25th and 26th: currently syncing across
July 27th: a very small set of customers may see these as syncing, but most customers should see this synced across.
July 28th to Aug 2nd: should be synced across
Aug 3 and 4th: A small amount of customers may see these as still syncing but these are expected to complete shortly.

If you see any invoices marked as 'Failed' with an error message of 'Rate Limit' or 'Error processing transaction' please click resync.
If the error message is different check your account mapping or let our support team know so we can follow up.
Posted Aug 04, 2024 - 19:28 EDT
Update
Overnight most customers will have seen takings data for July 18th complete off (we've re-queued a few datapoints for July 17th but most customers should have that through by now). About 50% of customers should also see their data for July 19th synced across.

July 20th and 21st has started the backfill process.
Posted Aug 01, 2024 - 19:56 EDT
Update
Since restoration of data syncing with Xero yesterday we have seen normal speeds resume on this process.

Overnight most customers will have seen all data for July 17th complete off (we've re-queued a few datapoints for July 16th but most customers should have that through by now).

Based on the speeds we saw overnight we're expecting around 3 days worth of data to sync across per 24 hours; with data completely caught up by end of day Saturday.
Posted Jul 31, 2024 - 18:33 EDT
Update
We wanted to update you on the active issue affecting our accounting integration that is resulting in rate limit errors when syncing invoices to Xero. As an interim measure, to help reduce these errors and ensure a smoother sync to the Xero and MYOB platforms, we kindly recommend the following steps:

Map Your Customer Accounts:
Mapping your customer accounts in the integration settings can help facilitate a more seamless synchronization process.

See our guide for steps on how to map your customer accounts here.

Retry Failed Invoices:
If you encounter any failed invoices, we suggest retrying them. This can help mitigate the rate limit errors and ensure your invoices are successfully synced to Xero and MYOB. Additionally, you can safely ignore any invoices marked as "queued" as they are already being retried in the background.

Check out our guide on how to resync invoices here.

We apologize for any inconvenience this may be causing. We continue to work towards a full resolution. If you have any questions or need assistance with these steps, please don’t hesitate to reach out to our support team.
Thank you for your patience and understanding.
Posted Jul 31, 2024 - 00:40 EDT
Update
Xero are currently experiencing a significant outage, details are available here.

Our backfilling efforts will be paused whilst we wait for Xero to come back online.
MYOB clients are still being backfilled as we speak.

Most customers should already see data from July 27th onwards already caught up and synced.
Data from July 16th and earlier should also be already up to date.

Most data is backlogged from July 17th to July 26th, we expect the data for MYOB to catch up shortly.
We will provide further updates once our process to backfill Xero is back online.
Posted Jul 30, 2024 - 19:48 EDT
Update
We are currently experiencing a longer than expected time-frame to work through the backlog of data exports to both Xero and MYOB.

We want to assure you that we are prioritising these exports and working to process them as quickly as possible. Our team is committed to resolving this backlog and ensuring all data is accurately and efficiently transferred.

If you are seeing invoices in a 'queued' state these are currently in an automated retry process and should eventually make it through.

Thank you for your patience and understanding. We will continue to provide updates as we make progress.
Posted Jul 29, 2024 - 01:21 EDT
Update
Our team are making some minor adjustments to increase performance on our end to work through the data backlog.

As a temporary measure, invoice sync history will only provide the last 25 transactions instead of 60 so we can dedicate resources to the export process.

We will return the sync history screen back to normal once this incident is resolved.
Posted Jul 24, 2024 - 20:04 EDT
Update
Our teams are still re-syncing data that has been queued up from last week; whilst a lot of customers are seeing their data come through now there's still some backlog for both MYOB and Xero that is still being worked through.
Posted Jul 24, 2024 - 00:53 EDT
Monitoring
MYOB and Xero were both impacted by the Crowdstrike outage on Friday.

Our systems are still working through a backlog of syncing data from Friday onwards due to accelerated loads on MYOB's API.

Please note that for Xero customers, a separate issue saw some customers see invoices remain "queued" for an abnormally long time starting from July 17th and a resync process was planned for this past weekend, this process is still in the works but running slower than expected due to Xero needing to recover their systems.

We anticipate most customers being back up to date my mid-week.

Note: If you have failed invoices from before Friday afternoon, please contact the support team so we can ensure our team have this chased up. Failed data syncs after Friday afternoon are already being worked on.
Posted Jul 21, 2024 - 20:38 EDT
This incident affected: Lightspeed Restaurant (O-Series) (Accounting Integrations).