Brand Portals - Degraded Performance

Incident Report for Lightspeed - Status Page

Resolved

Our Engineering team has identified and resolved a recent issue impacting performance of the brand platform for some users. The site is performing as expected once again and we will continue to monitor for any future degradation.
Posted Sep 23, 2026 - 12:00 EDT

Investigating

We have received reports of degraded performance within NuORDER Brand portals. Our Engineering team are currently investigating the problem and updates will be provided on this page when available. We apologize for the inconvenience caused in the meantime
Posted Sep 23, 2026 - 11:47 EDT
This incident affected: NuORDER (B2B) (The Brand Platform).