K-Series – Password Reset Non-Functional

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 13:37 EDT

Identified

We’ve identified a critical issue affecting password reset and account creation functionalities for K-Series. We’re working to resolve this as quickly as possible.
Posted Jun 20, 2025 - 13:18 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Back Office).