LSPay Issue with iDeal Payments in the Netherlands
Incident Report for Lightspeed - Status Page
Resolved
We identified the cause of the issue and have implemented a solution to correct it. Payments are again processing normally.
Posted Dec 18, 2024 - 05:33 EST
Monitoring
We have implemented a fix and will continue to monitor the situation.
Posted Dec 18, 2024 - 05:28 EST
Investigating
We are currently investigating an issue accepting iDeal payments affecting a subset of our LSPay customers in the Netherlands.
Posted Dec 18, 2024 - 04:53 EST
This incident affected: Lightspeed eCom (C-Series) (Lightspeed eCom (Europe)).