Lightspeed Restaurant (O-Series) - Updates & New Improvements 11.21.0

Scheduled for Oct 21, 00:00 - 01:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Tuesday, October 21 at 15:00 AEDT
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.

NEW
- Introducing Credit on Account, giving venues a simple way to issue, redeem, and refund customer credit directly through their POS. Perfect for managing member credit or handling customer deposits.

RESOLVED
- Fixed an issue where editing product availability for items within an option set failed if the auto-prompt setting was disabled.
- Fixed an issue where deleted categories blocked users from saving changes in the Courses add-on.
- Fixed an issue where users on the POS login screen were not sorted alphabetically by name.
- Fixed an issue where site-specific payment settings were not resetting correctly when only one site remains in a Company.
- Fixed an issue where certain products were missing from the Online Products page due to a mismatch between variant and parent product visibility settings.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Oct 14, 2025 - 21:41 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).