Restaurant (O-Series): POS not loading

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted May 29, 2025 - 23:49 EDT

Identified

Some customers are advising they are unable to load POS.

If you are having this issue, please perform a full app repair as described here:
https://o-series-support.lightspeedhq.com/hc/en-us/articles/31329410260891-Repair-Lightspeed-Restaurant-POS-O-series#h_36505890091539748005422

This should force your iPad to pull down our latest hotfix.
Posted May 29, 2025 - 22:37 EDT
This incident affected: Lightspeed Restaurant (O-Series) (POS).