O-Series: Insights Custom reports are not loading for some users

Incident Report for Lightspeed - Status Page

Resolved

This incident is now resolved.
Posted Mar 31, 2026 - 23:26 EDT

Identified

Our upstream provider is performing a rollback, there may be a brief disruption to Insights for approximately 20 minutes during this process. ETA for full restoration is approximately 2:30PM AEDT.
Posted Mar 31, 2026 - 22:32 EDT

Investigating

Our team is currently addressing a service disruption affecting Insights Custom reports. This appears to be related to an upstream provider, and we are engaged with their technical team to expedite a fix.

We will post another update once we have a clearer timeline for resolution.
Posted Mar 31, 2026 - 21:10 EDT
This incident affected: Lightspeed Restaurant (O-Series) (Insights).