Some customers are unable to take payments with Lightspeed Payments terminals
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 03, 2019 - 13:56 EST
Monitoring
Our third-party partner has applied a fix. We will continue to monitor the situation.
Posted Nov 03, 2019 - 13:30 EST
Update
We are continuing to investigate the issue with our 3rd party partner and will keep you updated as more information becomes available. Merchants may wish attempt manual entry in the Retail web browser as a workaround.
Posted Nov 03, 2019 - 13:18 EST
Update
Our third-party partner continues to experience a technical issue. Our technical teams are engaged and are troubleshooting the incident with the partner. Further updates will be provided as additional information becomes available.
Posted Nov 03, 2019 - 13:03 EST
Identified
One of our third-party partner is experiencing a technical issue. Our technical teams are engaged and are troubleshooting the incident with the partner. Further updates will be provided as additional information becomes available.
Posted Nov 03, 2019 - 12:36 EST
Investigating
We have identified an issue with Lightspeed Payments. A dedicated team is researching the issue. We will update you as more information becomes available.
Posted Nov 03, 2019 - 12:27 EST
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).